Como Avermedia (Philips Semiconductors SAA7133/SAA7135) en Ubuntu

Llevaba varios intentos para configurar correctamente esta tarjeta en ubuntu, este finde me he puesto farruco y lo he conseguido, aquí dejo los pasos a seguir:

  • Primero vamos a ver si el sistema reconoce la tarjeta:"dmesg | grep saa

    [ 39.847928] saa7130/34: v4l2 driver version 0.2.14 loaded
    [ 39.848432] saa7133[0]: found at 0000:01:05.0, rev: 209, irq: 21, latency: 32, mmio: 0xe8002000
    [ 39.848437] saa7133[0]: subsystem: 1461:2c00, board: UNKNOWN/GENERIC [card=0,autodetected]

    Si sale algo como esto ya la tienes configurada :

    [ 555.864000] saa7130/34: v4l2 driver version 0.2.14 loaded
    [ 555.864000] saa7133[0]: found at 0000:01:05.0, rev: 209, irq: 21, latency: 32, mmio: 0xe8002000
    [ 555.864000] saa7133[0]: subsystem: 1461:2c00, board: AVerMedia TV Hybrid A16AR [card=99,insmod option]

  • Comprobamos la tarjeta que tenemos:"lspci -v

    Multimedia controller: Philips Semiconductors SAA7133/SAA7135 Video Broadcast Decoder (rev d1)
    Subsystem: Avermedia Technologies Inc Unknown device 2c00
    Flags: bus master, medium devsel, latency 64, IRQ 21
    Memory at feaff000 (32-bit, non-prefetchable) [size=2K]
    Capabilities:

  • Desinstalamos los módulos cargados y que no están configurados :
    "sudo rmmod saa7134_alsa saa7134-dvb saa7134"
  • Por último cargamos los módulos correctamente con nuestra tarjeta:
    sudo modprobe saa7134 card=99"
    "sudo modprobe saa7134_alsa"
    "sudo modprobe saa7134-dvb"
    "sudo modprobe saa7134-dvb"

Publicado por Rubén García

Me presento, llevo mas de cinco años dedicado a la programación, diseño, gestión y administración de sitios web. Tengo experiencia profesional en JAVA y PHP, también conocimientos de SEO y soy usuario convencido de linux (ubuntu).

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *